BE4000 expedited maintenance in progress
Incident Report for Cisco Business Edition 4000
Resolved
The DNS issues have been resolved.
myphone.cisco.com is now now fully operational.
Thank you for your patience.
Posted Nov 16, 2017 - 17:42 UTC
Update
MyPhone.cisco.com is still undergoing maintenance, all other services are online and have been validated

Thank you for your continued patience
Posted Nov 16, 2017 - 13:53 UTC
Identified
The operations team are performing expedited maintenance on the BE4000 web portals to address redundancy concerns.

We aim to restore services by 12:00 UTC 16th November 2017

Thank you for your patience
Posted Nov 16, 2017 - 09:13 UTC